Bugs of BBB


From yesterday I’ve got some problems about the visualization of the maps.
It happens that the map it’s cutted in two pieces: north hexes are displayed in the south portion of the map, surrounded by nothing.
Here’s an example.

A part from the graphic problem, I can’t neither move the Ship in the deep blue hexes, where I should can go.

Thanks @JeanRenard. What happens when you scroll the map? The map wraps around, so it can appear split if your visible section is not centred on screen. Could you post a zoomed out pic showing more of the map?

Well, I add that when it shows me the replay, the camera is always on the deep blue hexes, and I’ve to zoom out to see my settlements.
Anyway here there are both of the games where I met this problem.

Hey, I would like to try and reproduce the issue here what browser and OS are you on?

Hey also, how easy is it for you to record a video that shows what is happening?

Chrome, Windows 8.
So easy, here you are: Buccaneers, Bounty & Boom! - End of the world bug - YouTube

Ahh, did you find the editor? There is a button in there that disables map wrapping. Perhaps that might be the issue.

I should hide the editor button becuase there are lots of bugs I need to fix there before its ready for everybody to use.

If that was not not case you could perhaps try clearing your cookies and temporary internet files to see if that helps.

Tanks for recording the video! Very helpfull!

Damn, that’s true! The problems begun when I tried the Editor!
Well I tried to re-open the Editor but it gaves me a black screen with “Loading” wrote on it.
I tried to delete the cookies ad the temporary files but it didn’t help.

Later today Penny or I will add the option to the normal game options, then you will be able to turn it on or off. Sorry for the inconvenience!

1 Like

This should be fixed now when you refresh. I’ve also removed the Editor button for now until we make it ready for everyone to use.

1 Like

Hyppieh! It works!
Thanks guys!

Great! Let us know if you find any more bugs! Thanks!

1 Like

Well, I found other two bugs.
One it’s the missed attack of an enemy ship, the second one is more complicated: before a settlement is created in a specific hexe, the settlement already created don’t harvest the hexe where the settlement will be created, obviously all in the same turn.
I recorded another video, hoping it helps.

Thanks for the video @JeanRenard. It makes it much easier to see the problem.

I’m not sure if you actually miss out on the resources, or there is problem with the animation playback.

1 Like

Ahoy! I’ve noticed that on the first entrance in a game the premium account is not considered (no golden icon, no possibility to custom the boats or the flag), and you have to enter again in the game to be effective that. Am I the only one that checked it?

I tried to fix that the other day with no luck. I will try again today.
(was a half hearted effort last time :))

1 Like

Ave. I’ve a problem with the visualization of the exclamation point in the Load Game screen, next to the title of the matches where I’ve to submit the turn. It doesn’t appear!

I’ve noted the same thing, the load game screen stopped showing which games are ready for my turn.

Yes Jay broke the exclamation mark showing yesterday when he was changing the email notification system, he’s fixing it now!

1 Like

That makes a lot of sense! I’ve also noticed I stopped getting the exclamation mark, and I also don’t think I’m getting new emails any more.

On another note, I came to post a bug I found on the 2-player map. I used a Ballooner to found a settlement in the interior of an island, but because there are no nearby water tiles, I cannot build a new ship to leave!

Here is an image describing the problem:

1 Like

That’s normal, I suppose. You sacrifice your Ballooner to make a new settlement.