Combat Pinning: Feature or Oversight?


#1

As I’ve written in other posts, I’ve been relying heavily on ranged attacks from bands of Elves.

Recently, while closing out Black Water Bog, I had a huge army of Elvin Archers aggressively cleaning up the zDwarf towns in the north by charging the towns, which by this point are severely diminished. So with 30 minutes until battle at Rams Crag, a group of 25 Archers knocked off the last few defenders before the battle had even commenced. Hooray, but when I immediately tried to move them to the next town and was unable because it still showed combat occurring in 30 minutes. I rationalized it by thinking it would take an army preparing for battle some time to prepare to move again.

So Jay feature or oversight?

Thanks,
Sparkster


#2

Hrm… That sounds like a bug. There is code to release units from combat pin when thier enemies are killed by a ranged attack!

I will log it.


#3

Thinking back on it, I tried to move the unit immediately after the attack and I do recall it seemed to unlock 10 minutes later or so without a Time Jump, so maybe it was impatience.

FWIW,
Sparkster


#4

I think if you refresh the game data (without doing a jump forward) it’ll be released from combat. You have to do that sometimes in MP as well.


#5

tip: You can do this by clicking on the Age in the blue bar at the top of the screen.


#6

This strategy has always worked for me when encountering this bug.