iOS 10 bug


Just updated my iPhone to iOS 10 and there is a bug where the keyboard shows up at inoppurtune times, very very often. Lots of times when I tap a star, or purchase anything in the galaxy screen. I play almost exclusively on mobile so this slows me down, but I get it if it isn’t top priority with all the Proteus upgrades rolling out.



As soon as we wet the update here I will debug it and fix it. A day or two.


Cool, thanks!


Hey guys, I just got the iPhone7 and I’m not seeing the same bug that hero referenced, but I experienced it a lot on the 6s. Not sure why it would be different, but it’s very relieving to have the navigation back in order.


I spent some time looking at this yesterday.

I dont know yet why the keyboard popups up all the time, its happening in both Blight and Neptune’s Pride.

They also changed how the viewport tag works on iOS 10 but I have a fix for the screen stuck in just a small part of the screen.


Updated today to iOS 10, using iPhone 5s and it works OK for me. I’m using Safari.


I’m on the iPhone SE so that’s different from Hip.

It’s a little better recently, I don’t see it nearly as often. It still pops up a few times a day though. (This might be because I’m playing less than a few days ago)


Did you upgrade to ios 10?


Yes, never happened before I updated. I similar glitch happened on a couple different HTML games, but only once or twice it’s been pretty constant with Neptunes pride so I don’t know what triggers it. It’s occasionally pulled up the Intel screen drop down when I type a message also.


I’m getting the same bug in the 6 plus. Safari is that helps. Should I try chrome?


As of this morning I’m not getting the keyboard at all, but the Intel drop down pulls up every single time I click a star. Also just noticed this (haven’t tried til now). Completely unable to rename stars on iOS 10 because the Intel drop down comes instead of the keyboard.


I’ve been googling around about how to fix it. We might just find its a bug in Safari and we have to wait for apple to fix it.

Anyhow, I’ll do some more work on it later today.


I tried chrome to check, and I’m getting the same problem. Not the keyboard (so far) but the drop down menu.

So it’s not just safari…


on iOS its all Safari.

Chrome on iOS is just a wrapper around Safari.

I have a fix, but its a big change and I have been testing on all kinds of devices all day.


Glad you’ve got a fix in the works.

Not sure if this has been noted yet, but it happens in the menus as well. I didn’t notice until today because I just leave a tab open for every game I’m in and don’t navigate through menus unless I’m creating or joining a game.


Working better now?

Can you look at the tech spinner because I have only tested on iPad and it works different there.


It worked better for a minute. I renamed a star and it was fine. Then I tried to buy an eco point from the star page and the keyboard came. After that it was back like usual.


Something new on the tech spinner (I think this is what you mean) is that it zooms in all the way whenever I tap it.


doh! did you remember to refresh?

Also, apple is no longer allowing people to lock the zoom levels so if you double tap on anything the game will zoom now.