Possible Bug?


#1

Or maybe it’s just me.
Game is: https://np.ironhelmet.com/game/4861876187168768

Keep getting “Cannot contact server”

I can submit my turn in other games I am playing.
This is the second time this has happened, the first was in a game with me vs 15 AI. 24 hour jumps.

This game is me and another player vs 30 AI.
6 hour jumps this time.
Just as in the other game, once I have gained momentum and it seems I’ll keep the lead, the game stops allowing me to submit my turn.
At first I thought it might be me.
I’ve cleared cache/cookies and tried a different browser.
Tried different wifi connections and my cells data.
It allows me to buy econ and saves it, but the submit doesn’t work.
Is there any way to check on the back end and see what’s going on?

Edit:
I noticed when I get the error, it still shows my turn as submitted until I reload the page.


#2

Really large games can bog down the servers … I remember a crazy game a while back where the number of ships was in the millions … and it just ground to a halt. My guess is having 30 AI’s is probably computationally intensive also … so the browser times out while the server (which took your submit) is still calculating.

So yea, click submit, wait a while, and then reload is probably the best you can do.


#3

Tried that, turns out using the “Restore Player” feature on the automatons will cause them to submit the turn and it can progress, but then you have to force turn 3 times before they become AI again.
Just gonna delete it :confused:
No point with a 3 turn advantage