Record of non-reproducable fleet waypoint bug (Discord chat logs)


This is a full chat log of all related comments about a bug affecting a single user, ALdeign, which no one was able to reproduce. If anyone can reproduce this please post how you did it and what you changed.


ALdbeign#6909 [24-Apr-18 12:18 AM]:
I have having multiple and repeated issues adding waypoints
ALdbeign#6909 [24-Apr-18 12:18 AM]:
so far, my workaround is to ignore the error message, go to main menu, then select my game again
ALdbeign#6909 [24-Apr-18 12:19 AM]:
if i head the error message, it will remove my new waypoints.


ALdbeign#6909 [05-May-18 01:45 AM]:
i’ve seriously considered an upgrade but honestly this “fluke” issue with setting waypoints has been a deal breaker.
ALdbeign#6909 [05-May-18 01:45 AM]:
this is a problem that needs to be fixed.
ALdbeign#6909 [05-May-18 01:46 AM]:
game seems pretty cool overall, but i cant pay for a game with the above error

AnnanFay#0634 [05-May-18 02:15 AM]:
@ ALdbeign#6909 If you want to try narrowing down what’s causing the issue you can open up the developer console and see if it’s something client side. F12 to open the console. Then to see any errors you make sure Console is selected., If there’s no errors then click Network to see if there’s a network problem, all the requests should be 200 or 3xx (cached). 5xx will mean there’s a server error., Other than that, keep pestering @ IHG#3364
ALdbeign#6909 [05-May-18 06:30 AM]:
Something like this?

ALdbeign#6909 [05-May-18 06:30 AM]:
@ AnnanFay#0634 @ IHG#3364
IHG#3364 [05-May-18 07:01 AM]:
I think that one happens when you deselect a fleet while the fleet waypoint screen is open.
ALdbeign#6909 [05-May-18 07:36 AM]:
i dont deselect though
ALdbeign#6909 [05-May-18 07:38 AM]:
my current “workaround” is to set a way point, get an error, go to the edit screen, change what the carrier will do (even if the preselect is what i want), then refresh and hope it sticks
ALdbeign#6909 [05-May-18 07:38 AM]:
sometimes, this takes 2-3 tries
ALdbeign#6909 [05-May-18 07:39 AM]:
sometimes more, i rage-quit one of my first games after an hour of trying to make a waypoint edit stick
ALdbeign#6909 [05-May-18 07:39 AM]:
(mind you i have yet to complete a game)
ALdbeign#6909 [05-May-18 07:41 AM]:
@ IHG#3364
IHG#3364 [05-May-18 07:42 AM]:
That is very weird, I will look into it for you. Can I ask what browser and OS you are using?
IHG#3364 [05-May-18 07:43 AM]:
In order for you to get that error it means the server is crashing anyhow. It wont be a bug in the client javascript.
IHG#3364 [05-May-18 07:43 AM]:
@ ALdbeign#6909
ALdbeign#6909 [05-May-18 07:49 AM]:
i am on win10 and Chrome 65.0.3325.181 (Official Build) (64-bit)
ALdbeign#6909 [05-May-18 07:49 AM]:
i am also apparently due for an update, wasnt there 20 mins ago lol
ALdbeign#6909 [05-May-18 07:50 AM]:
and thank you @ IHG#3364
IHG#3364 [05-May-18 09:23 AM]:
Hey Also @ ALdbeign#6909 is this in the 64 player games. Are you in any smaller games? I think the 64 player games might be pushing the server a little hard lately.
ALdbeign#6909 [05-May-18 05:21 PM]:
@ IHG#3364 I had one of those that i quit because after an hour i couldnt get one way point set. I am in an 8 real time player game and also a Turn based 8 player
AnnanFay#0634 [05-May-18 05:44 PM]:
Well, I found one way to trigger a similar bug. If you are editing a fleet order ( and manually reload the game by clicking the top-bar then the error happens.
AnnanFay#0634 [05-May-18 05:45 PM]:
I’m not sure if this is the same situation where @ ALdbeign#6909 is having the bug. Is it this screen or another screen when it happens?
ALdbeign#6909 [05-May-18 10:03 PM]:
@ IHG#3364 i am also getting this warning which may (or may not) be related:
ALdbeign#6909 [05-May-18 10:03 PM]:
jsapi:22 A parser-blocking, cross site (i.e. different eTLD+1) script,,default+en,ui+en,corechart+en.I.js, is invoked via document.write. The network request for this script MAY be blocked by the browser in this or a future page load due to poor network connectivity. If blocked in this page load, it will be confirmed in a subsequent console message. See for more details.
ALdbeign#6909 [05-May-18 10:03 PM]:
i personally have gigabyte fiber so i dont think i have connection issues…
IHG#3364 [05-May-18 11:25 PM]:
@ ALdbeign#6909 I think the jsapi issue a separate issue I will look into at some stage. Its just a warning i think, not an actual error. It might just be where in the file I’m loading the javascript.
ALdbeign#6909 [06-May-18 02:44 AM]:
that’s cool @ IHG#3364 , i thought as much also but didn’t want to leave anything out.
IHG#3364 [06-May-18 06:50 AM]:
@ ALdbeign#6909 Thanks.


ALdbeign#6909 [22-May-18 02:32 AM]:
@ IHG#3364 i still get constant fleet waypoint issues, on a wiold hair, i logged off with my laptop to ensure that i was only logged in from one comp…this did not fix the issue
ALdbeign#6909 [22-May-18 02:34 AM]:
the odd of me being here in a week are slim given your indifference, mind you, i dont think i am anyone special lol
ALdbeign#6909 [22-May-18 02:35 AM]:
not being able to set way[points without excessive efort is a big deal to me.
IHG#3364 [22-May-18 03:03 AM]:
Thanks @ ALdbeign#6909 I really not sure what the issue is. I don’t think a lot of other players have the issue?
IHG#3364 [22-May-18 03:03 AM]:
It might just be the 64 player games. Do you have the same issue is smaller 8 and 16 player games?
IHG#3364 [22-May-18 03:04 AM]:
Is there something special about the game that might cause the problem.
IHG#3364 [22-May-18 03:05 AM]:
I think I asked before, but do you have any extensions installed on your browser that might be altering the requests to the server.
IHG#3364 [22-May-18 03:06 AM]:
Oh, i see you are just in 2 8 payer games
AnnanFay#0634 [22-May-18 10:40 AM]:
@ IHG#3364 Did you see my post about how to trigger a bug with the same error message while editing fleet paths? Not sure if it’s the same bug, but it’s similar enough that it might be related., I’m not sure how to link to previous posts but searching for from: AnnanFay#0634 "to trigger a similar bug" brings it up.


ALdbeign#6909 [09-Jun-18 02:08 AM]:
It has been nice meeting a few folks here., I am no longer going to play this, far too buggy for my tastes. this game has been around more than long enough for seriously annoying issues (like being unable to set waypoints) to still exist,
ALdbeign#6909 [09-Jun-18 02:10 AM]:
to discount these problems as being a “free version” issue and therefore unimportant makes no sense since the “free version” is what folks like me look at before deciding to spend money
ALdbeign#6909 [09-Jun-18 02:10 AM]:
game has potential, but honestly not enough given the age of the game.
ALdbeign#6909 [09-Jun-18 02:11 AM]:
I wish you the best though :smiley:
Axson#1041 [09-Jun-18 07:47 AM]:
I’ve never had a problem with setting waypoints.
Affordable_Desk#2112 [09-Jun-18 11:26 AM]:
@ ALdbeign#6909 I can’t see your original complaint, what’s the waypoint problem?
AnnanFay#0634 [09-Jun-18 11:37 AM]:
@ Affordable_Desk#2112 He gets the red “Error Processing Order” message every time he tries to set fleet waypoints. Apparently this happens on different devices (chrome and a tablet browser - possibly also chrome). He was quite helpful and posted some javascript error logs. No one else has ever complained of this issue as far as I know and no one can reproduce it. I got a similar error by reloading the game data while editing waypoints, so fixing that bug might have fixed his issue. IHG thinks it’s a server side problem though.


ALdbeign#6909 [21-Apr-18 01:18 AM]:
yeah, i have bigger issues, i quit oe game since it wouldn’t let me create waypoints
ALdbeign#6909 [21-Apr-18 01:19 AM]:
now , i am getting these errors in both of the games i’m currently playoing
AnnanFay#0634 [21-Apr-18 01:19 AM]:
Hmm, so it’s worked in the past but is not working now?
ALdbeign#6909 [21-Apr-18 01:20 AM]:
the 8 player game it worked fine at first
ALdbeign#6909 [21-Apr-18 01:20 AM]:
the real-time 64 player game was just flipping on me and i finally got to frustrated and quit
ALdbeign#6909 [21-Apr-18 01:21 AM]:
the turn-based game gives me an error but also lets me set up way-points
AnnanFay#0634 [21-Apr-18 01:22 AM]:
What error message?
ALdbeign#6909,21-Apr-18 01:23 AM,
ALdbeign#6909 [21-Apr-18 01:24 AM]:
the 64 player game i quit yesterday
ALdbeign#6909 [21-Apr-18 01:24 AM]:
i got that over 20 times in an hour, i gave up and quit
AnnanFay#0634 [21-Apr-18 01:24 AM]:
I’d begin by: 1) force reload page (ctrl+F5), 2) clear browser cache, 3) try other browsers
AnnanFay#0634 [21-Apr-18 01:25 AM]:
If that doesn’t work post a bug report in the forum.
ALdbeign#6909 [21-Apr-18 01:25 AM]:
i did all of that over that hour
ALdbeign#6909 [21-Apr-18 01:25 AM]:
also, i dont become a bug reporter my first day playing a game lol
ALdbeign#6909 [21-Apr-18 01:25 AM]:
i find another game
ALdbeign#6909 [21-Apr-18 01:26 AM]:
the game appears to have potential
AnnanFay#0634 [21-Apr-18 01:27 AM]:
Eh, it’s just really weird - I try to fix problems when I hear about them
ALdbeign#6909 [21-Apr-18 01:27 AM]:
and the smaller (8 player game) wasnt giving me this issue
ALdbeign#6909 [21-Apr-18 01:27 AM]:
the turn based game, it gives me this message but it actually sets up my waypoints
ALdbeign#6909 [21-Apr-18 01:28 AM]:
so just a fake error
AnnanFay#0634 [21-Apr-18 01:33 AM]:
Yeah, the error messages are pretty useless. You can get that error if there’s a server problem, a client problem, an illegal request or an internet connection problem.
IHG#3364 [21-Apr-18 09:24 AM]:
There may have been some server issues yesterday. Not sure

IHG#3364 [24-Apr-18 11:00 PM]:
I just pushed out a new build with a few minor bug fixes. Please ping me if the game is crashing
ALdbeign#6909 [24-Apr-18 11:01 PM]:
do any of these minor bug fixes involve the constant errors when setting waypoints?
IHG#3364 [24-Apr-18 11:01 PM]:
nope. Is this in the 64 player game?
ALdbeign#6909 [24-Apr-18 11:02 PM]:
i am getting them in both games i play, i quite a 64player game over this issue though
ALdbeign#6909 [24-Apr-18 11:03 PM]:
i am able to bull through the problem but setting the way points, ignoring the issue, going to the main menu, re-entering the game, proceding with edits to the way points
ALdbeign#6909 [24-Apr-18 11:03 PM]:
if i rsresh in any way like the error suggests, all my edits are erased
ALdbeign#6909 [24-Apr-18 11:04 PM]:
IHG#3364 [24-Apr-18 11:07 PM]:
hrm wierd.
IHG#3364 [24-Apr-18 11:07 PM]:
What platform are you on.
ALdbeign#6909 [24-Apr-18 11:07 PM]:
i have had this issue for as long as i have been playing (which is less than a week lol)
IHG#3364 [24-Apr-18 11:07 PM]:
Desktop or Mobile. PC or Mac or
ALdbeign#6909 [24-Apr-18 11:07 PM]:
PC win10
IHG#3364 [24-Apr-18 11:07 PM]:
Edge, IE, Firefox, or Chrome or other
ALdbeign#6909 [24-Apr-18 11:08 PM]:
i did log in briefly on my mobile in response to an alert
ALdbeign#6909 [24-Apr-18 11:08 PM]:
IHG#3364 [24-Apr-18 11:08 PM]:


@AnnanFay , please notify @ALdbeign to read this forum post, since he might miss it.


Browser Google Chrome is up to at least version 67.0.3396.79 , so update if you are out-of-date.

After update, close the browser, wait 60 seconds before opening the browser.

There is often a new update for browser Google Chrome once every two to four weeks.

CTRL+F5 is not a valid shortcut key for browser Google Chrome.
Use either F5, or SHIFT+F5.

First select a carrier, then shortcut key “W” enters mode Edit Waypoints.

During mode Edit Waypoints, if you click the square “X” or if you hit key “ESC”, then that cancels your edits and retains no changes.

During mode Edit Waypoints, be sure to click either button “SAVE” or button “SAVE & EDIT” .
To avoid bugs, always make sure that your current mouse tasks plans are complete before moving on to another task.

After you have properly exited mode Edit Waypoint, for that carrier, re-enter mode Edit Waypoint to re-check your waypoints that you have set for that carrier.

During mode Edit Waypoints, do not make the mistake of deselecting the carrier, and do not become distracted selecting something else, and do not make the mistake of right clicking anything.

During mode Edit Waypoints, mouse dragging the map is ok.

Click round “x” to clear all waypoints.

Click round “-” to delete final waypoint.

When viewing the list of waypoints for a carrier, you can click orange EDIT to adjust the carrier action at a star.

When satisfied with the desired carrier action, click button “OK” to accept changes.
Do not click the square “X” .
To avoid bugs, always make sure that your current mouse tasks plans are complete before moving on to another task.

Select that carrier again to verify your carrier actions at each star.



Be sure to read the NP2 help files about shortcuts keys.

Shortcut key “O”, opens the Options menu.
My favorite settings are :

Map Graphics = Low , maybe reduces CPU load and maybe Internet bandwidth load.
Main Menu = Drop Down
UI position = Left
Galaxy Screen = Allow Upgrades
Audio = On

Ship Count = 150
Star Names = 350
Infrastructure = 250
Player Names = 1550 , I can right click any star or carrier to identify that stench of the evil galactic overlord

Default Action = Garrison Star , saves most mouse clicks
Default Amount = 1 , gives me defender’s first strike advantage




It is true that clicking the top bar (showing your cash available & countdown timer to production) will refresh & update game data, but do not click on that until you have properly saved & exited mode Edit Waypoint. The same goes for any mode edit carrier actions, or any other intermediate data entry command modes.

You have to make sure your orders have been first saved & sent to the server, allow a two second delay, before requesting a return update from the server.


Thanks very much guys for following up on this bug for me.

Even though we only have one guy telling us, there might be a lot more people out there who experience the bug but dont tell us.

I will see if I can find the time to track it down very soon! It probably should be my top priority!

update: Looking at the code now…

    npui.EditFleetOrder = function (screenConfig) {

        blar blar
        efo.fleet = universe.galaxy.fleets[screenConfig.fleet];

ScreenConfig must be undefined

Edit order show screen event only triggered from three places in the whole project

As a hyperlink template here....

    "edit_fleet_order_link":"<a onclick=\"Crux.crux.trigger('show_screen', ['edit_order', {order:[[index]], fleet:[[fuid]] }])\">Edit</a>",

    and when you click the next and last buttons.

    efo.trigger("show_screen", ["edit_order", {order:[[index]], fleet:[[efo.fleet.uid]] }]);


I can reproduce the error message buy attempting to refresh the games data by clicking on top menu, while the edit order window is open. Annan could repro it as well.

I bet I know what is happening, He sends one order off to the sever, but the connection is so slow that he is already editing the next order buy the time the server responds. I will add some artificial delays to my dev server to see if this would cause the issue.


Nope, that wasn’t exactly it. Only orders that respond with full universe data crash the screen. Editing fleets only respond with an OK response.


OK, one last update on this bug tonight. I have a fix for the error that was in the console above, but I don’t want to push it out tonight because I’m about to go to bed and I want to be around to fix any problems that might I might cause in fixing the issue. I will push it out tomorrow morning.

However, I’m pretty sure this is not the error that is driving @ALdbeign crazy because it doesn’t result in the red box that says Error Processing Order…


If I make the mistake of clicking the (credits & production timer) bar while the carriers action list is open,

then I get an infinite loading non-responsive screen.


I then hit F5 to refresh my browser Google Chrome, and recover and continue.


Yes, this one should be fixed… But I just found if you do a refresh of data while editing waypoints there is another similar bug that requires a full browser refresh. Looking at that one now.


If I forget to click “OK”, before clicking top bar (credits & production timer) to request refresh game data,


then I get the same error, infinite LOADING non-responsive screen.
(Well, it just does not work right, until I hit F5 to refresh my browser tab.)


So I workaround that by always clicking “OK” first, and waiting 2 seconds before I do anything else.


As a quick fix, which at least means you don’t have to refresh the browser, if you get a full universe update while editing fleets, the game kicks you out of the fleet editing screen. I will submit tomorrow.

One other change I will submit tomorrow is to remove the code that was requesting new data every few minutes. Browsers made some changes to how tabs in the background make requests and this might be a little broken now.


If I add waypoints without clicking either “SAVE” or “SAVE & EDIT”,
then make the mistake of clicking the top bar,


then the GUI stops working correctly.

I hit F5 to refresh the browser tab, and recover.


I think there are a few more other data entry command modes that have similar issues.


Clicking the top bar does not clean up & kick out of the chain ruler mode.

Simple workaround is too always exit chain ruler mode before clicking to request server refresh game data.


clicking the top bar without first clicking “OK” on the Bulk Infrastructure Upgrade screen


will produce infinite LOADING screen.

It is best to make sure your commands are saved before clicking to request server refresh game data.


I am often looking at safe normal ways to speed up my CPU or reduce memory usage.
I often have 100+ tabs open in my browser Google Chrome. LOL ( Don’t tell me that I am crazy ! )
I usually have a tab open to watch browser Google Chrome, and get more familiar with its behavior.

Browser Google Chrome / top right corner there is the 3 dots menu / More Tools / Task Manager

Heading bar / right click / check = MEMORY
column MEMORY left click = sort ascending
I scroll to the bottom to watch the memory & sometimes CPU usage.
I will also compare with Windows 10 Task Manager.

I think if you keep a tab open too long on anything, even an NP2 game, especially Google Maps, and others, some of those tabs accumulate & grow in memory consumption if they are open for too many days or weeks. I will usually copy the hyperlink to clipboard, close that tab, wait 4 seconds or longer for the memory to deallocate, open a new tab, paste hyperlink, to refresh that tab. I do the same thing if the CPU usage goes up too high on a tab.

I know it is safe for task = “GPU Process” to click “End Process”. It will safely restart.
Also if your PC is attacked by a hostile popup using social engineering phishing attacks or other hacker virus malware attack, you should attempt to click “end process” on those tasks too.
Be careful with that button, because you do not know whether you can damage something on your PC.

I think Windows 10 also does some kind of live RAM usage compression, which can sometimes occasionally hang, trip over itself, or have problems, closing the offending browser tab or application, can help reset the problem.



Along this similar issue. The mode “Quick Upgrade” does not exit when I hit key “ESC”.

It would be nice if anytime I click the top bar (credits & production timer), it should go ahead and hit key “ESC” for me to exit any mode.


thanks. I will add to to todo.