Blight Beta: Known Issues and Bugs


#556

5397268284833792


#557

Should be fixed, thanks for the heads up.


#558

I’m having auto redraw kick in with 7 cards in my hand. Is this intended behavior?

5 seemed fine before…


#559

Just an issue with existing games, where the hand size was 7.


#560

New Bug: Target out of Area
End game on a SP and I’m trying to speed up my Dwarf army, so I hit the horn (of Gryphon, that is) and see the following:

When I hit “OK,” I get:

I reloaded the browser and even quit the browser, but no fixie. Ultimately, it didn’t matter, but thought I should file it.


#561

Thanks Sparkster, Looks like the client and server dont agree to what is in range here.

I will see if I can reproduce the issue and fix later today.


#562

I jumped ahead 6 hours and was able to do it, FWIW.


#563

I’ve got a Volunteer bug.

I picked up a Volunteer Jolly Tavern Keeper (score!) in this game. However, he’s not providing his buff to anyone (not even himself). A full page refresh does not fix the problem, so now I’m pretty much using him as a slow Wolfpup Handler… no free beer today! :frowning:


#564

Ok, will look into it now.

edit: Submitting a fix to the server now. I was failing to activate the powers on units that trigger when they spawn. (Army powers basically)

Unfortunately because this guys is already spawned he missed his chance to cast his spell.


#565

Same game: Anything I deploy at my Dragon Banner is being sourced from a random city in the south, instead of the nearest city.


The screenshot above shows all the Orc settlements on the map. It’s still early in the game, so I know exactly what I’ve deployed where. This list indicates all my plays, as well as how much population each card should have taken from what settlement. Starting from the top left:

  • Narrowburning
    • Deployed 50 Orcish Swords card (pop -50)
  • Hidden Burnnig
    • Volunteer Tavern Keeper (pop -1)
  • Goats Village
    • Deployed Dragon Banner at game start (pop -1)
    • Trained two units of Orcish Swords (pop -100)
  • New Arid
    • Volunteer Elder Shaman (pop -1)
    • Recruited Shaman Priestess (pop -1)
  • Dragon Banner
    • Deployed Butcher at game start at Goats Village (Goats Village pop -1)
    • Deployed Vicious Sergeant near New Arid (New Arid pop -1)
    • Deployed Desert Maiden at Winter Lair (Bloodsness pop -1)
    • Deployed 50 Orcish Swords at Winter Lair (Bloodsness pop -50)

Given all this, I would expect New Arid to have a remaining population of 197, and Bloodsness to have 149. However, the only card that seems to have been sourced correctly for the Banner was the first one from Goats Village. The other three cards I’ve deployed at the Banner appear to have drawn their population from Priests Barren, way in the south.


#566

New Bug: Spider Pennon not able to draw from adjacent village.

Got a weird one here. Playing a SP Goblin game and in a desperate losing situation where I’m Mad Pirating my villages to generate enough gold to fight off a constant stream of zSpiders. In this scenario, the Pennon is essential to get Goblin troops near the front-line. In my case, I get a “No location to source civilians” error when the Pennon is sitting on the depleted village of Southponk, even though the populated village of Snails Tangle is one-klik away:

If I had to guess this is an odd corner case bug, as the immediate village isn’t blighted, but also no population. That said, moving the Pennon to the nearby Eagles Web didn’t resolve the problem. I kept getting the same error, so he’s now being digested in a zSpider’s stomach in a brave, but futile attempt at keeping the horde at bay for another few hours…

FWIW,
Sparkster


#567

Thanks for the heads up Sparkster, Looks like I have a couple of bugs to fix with banners on Monday morning.

I think Penny and I decided that Banners should also only draw from locations you command so that you can’t pull from other players people and damage thier economy and perhaps even prevent them from playing characters in thier deck.


#568

Oh, I assumed that was already the case.


#569

I found these deploy bugs and fixed them today. It was yet another case where the units position was not calculated correctly when the unit was in a stack. I’m going to fix this at the root cause when I get time.


#570

I’ve got a new bug in this game. That big group of spiders, near the middle on the right, won’t show its details. It’s under the effects of the Jester King and its own chaos webs, if either of those are useful info.

There are two Javascript errors being shown:

Uncaught TypeError: Cannot read property ‘length’ of null
r.drawPath @ blight.807.min.js:13
r.draw @ blight.807.min.js:14
Crux.mainLoop @ blight.807.min.js:3


Uncaught TypeError: Cannot read property ‘length’ of null
e.calcPathEtas @ blight.807.min.js:9
a.getEtaString @ blight.807.min.js:9
r.onOneSecondTick @ blight.807.min.js:11
e.UnitEssentialsZombie @ blight.807.min.js:11
e.UnitEssentialsPanel @ blight.807.min.js:11
e.UnitScreen @ blight.807.min.js:11
n.onShowScreen @ blight.807.min.js:10
dispatch @ blight.807.min.js:17
_.handle @ blight.807.min.js:17
trigger @ blight.807.min.js:17
(anonymous function) @ blight.807.min.js:17
each @ blight.807.min.js:16
each @ blight.807.min.js:16
trigger @ blight.807.min.js:17
o.trigger @ blight.807.min.js:7
o.onShowUnit @ blight.807.min.js:8
dispatch @ blight.807.min.js:17


#571

Looks like his webs have worn off now. I can selecting him ok. Did it fix itself.

I will have a look for what might cause it! I would say something to do with not having a path. The Crash is in calculating the eta.


#572

It hasn’t fixed itself for me. Reload and browser relaunch don’t fix it either. I’m on Chrome, by the way, and I’m seeing the same problem on mobile (also Chrome).

His webs shouldn’t be expiring for about another 1.5 hours from the time of this post. According to the Combat log, the combat that trapped them was at 5d 2h 17m.


#573

Small issue I noticed today. I got a volunteer Dragonhelm Knight from a town I recruited and a small force of 3000 something dwarves and human swordsmen. When I set Dragonhelm Knight as leader of my army, my 3000 score went to 450, setting up someone else as leader solves the issue.
Might be because of the voluenteer thing but I wanted to let you know.


#574

This I’m assuming is a bug, because otherwise it’s a pretty lousy feature…

discarding with more than 5 cards doesn’t auto draw you another.

I’m pretty sad I just spent a Valor to make my hand worse :confused:


#575

Sorry, thethanx, but I thought auto-draw only worked if you had less than 4 cards.

Well, that’s how I read it anyway…